aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-14 23:27:36 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-14 23:27:36 +0200
commitcb0e6ec211aca54fb46a3722d63cf0f896995d9d (patch)
tree3628a0256cb57d2f8348b79e5400c8c2cfd5cc2c
parentc8e2358cca79f24a0f1183d806e9dd00d6951712 (diff)
downloadguix-cb0e6ec211aca54fb46a3722d63cf0f896995d9d.tar
guix-cb0e6ec211aca54fb46a3722d63cf0f896995d9d.tar.gz
gnu: Add xpadneo.
* gnu/packages/linux.scm (xpadneo): New variable.
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b766ede5c0..b0ad62eff9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1582,6 +1582,41 @@ allows some more serious things like adding streaming capabilities to an
application by hooking GStreamer into the loopback device.")
(license license:gpl2+)))
+(define-public xpadneo
+ (package
+ (name "xpadneo")
+ (version "0.9.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atar-axis/xpadneo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xr0zx134s56h4ij6c3fh8ki0h58h61minbfxcl3sgpgxkh14ism"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f ; no `check' target
+ #:source-directory "hid-xpadneo/src"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively "hid-xpadneo/etc-modprobe.d"
+ (string-append out "/etc/modprobe.d"))
+ (copy-recursively "hid-xpadneo/etc-udev-rules.d"
+ (string-append out "/etc/udev/rules.d"))))))))
+ (home-page "https://atar-axis.github.io/xpadneo/")
+ (synopsis "Xbox One Wireless Controller driver")
+ (description
+ "This package provides a driver for the XBox One S Wireless controller
+and some newer models when connected via bluetooth. In addition to the kernel
+module provided itself, it also contains a modprobe configuration and udev
+rules, which need to be installed separately.")
+ (license license:gpl3+)))
+
;;;
;;; Pluggable authentication modules (PAM).