aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-15 19:28:43 +0200
committerMarius Bakke <marius@gnu.org>2021-09-15 23:38:51 +0200
commit16110ba476d90d0fb5b2921eb57f42f8faa3623c (patch)
treef68fbc77c70c27ea3cad7a9cb69351d44a9d5a0c
parentd0e23782dff3c93a23be40150adca0419d10c924 (diff)
downloadguix-16110ba476d90d0fb5b2921eb57f42f8faa3623c.tar
guix-16110ba476d90d0fb5b2921eb57f42f8faa3623c.tar.gz
gnu: python-wtforms: Adjust for SQLAlchemy >= 1.4.
* gnu/packages/python-web.scm (python-wtforms)[arguments]: Add phase to delete test.
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 785669410b..ac9245ac7b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4163,6 +4163,12 @@ addon modules.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'delete-bundled-test
+ (lambda _
+ ;; Delete test copied from a third party package that fails
+ ;; with newer SQLAlchemy. This can be removed for 3.0.
+ ;; See <https://github.com/wtforms/wtforms/issues/696>.
+ (delete-file "tests/ext_sqlalchemy.py")))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?