aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPradana AUMARS <paumars@courrier.dev>2021-09-05 10:25:14 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-14 11:50:59 +0200
commit1289d4119e1865fff09d6ff7736655b6ca1e97fc (patch)
tree1f39e30316be12e7d795b5e0f005172bd76fa66f
parented91e7a23c1ee9eaed58f0fc536725376fd34448 (diff)
downloadguix-1289d4119e1865fff09d6ff7736655b6ca1e97fc.tar
guix-1289d4119e1865fff09d6ff7736655b6ca1e97fc.tar.gz
gnu: Add python-w3lib
* gnu/packages/python-web.scm (python-w3lib): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bd390d371d..9ff819f682 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6210,3 +6211,25 @@ your code non-blocking and speedy.")
"This project provides a client library in Python that makes it easy to
communicate with Microsoft Azure Storage services.")
(license license:expat)))
+
+(define-public python-w3lib
+ (package
+ (name "python-w3lib")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "w3lib" version))
+ (sha256
+ (base32
+ "1pv02lvvmgz2qb61vz1jkjc04fgm4hpfvaj5zm4i3mjp64hd1mha"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/scrapy/w3lib")
+ (synopsis "Python library of web-related functions")
+ (description
+ "This is a Python library of web-related functions, such as: remove comments,
+or tags from HTML snippets, extract base url from HTML snippets, translate entites
+on HTML strings, among other things.")
+ (license license:bsd-3)))