aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:04:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:22 -0400
commitabb9adfff89d33415b53ef758e6323bc1de46330 (patch)
tree97bf812b6df40747a1231f8fd584e65c47cf9727
parent76cebcc03dd563aca4c62ac74f14512a3c0fd18e (diff)
downloadguix-abb9adfff89d33415b53ef758e6323bc1de46330.tar
guix-abb9adfff89d33415b53ef758e6323bc1de46330.tar.gz
gnu: Remove python2-setproctitle.
* gnu/packages/python-xyz.scm (python2-setproctitle): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e694ba0feb..cd60cd201d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18580,15 +18580,7 @@ JSON) codec.")
example when a master process is forked: changing the children's title
allows identifying the task each process is busy with. The technique
is used by PostgreSQL and the OpenSSH Server for example.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-setproctitle))))))
-
-(define-public python2-setproctitle
- (let ((base (package-with-python2
- (strip-python2-variant python-setproctitle))))
- (package/inherit base
- (native-inputs `(("python2-nose" ,python2-nose)
- ,@(package-native-inputs base))))))
+ (license license:bsd-3)))
(define-public python-validictory
(package