aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-04 10:02:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-04 10:02:40 +0300
commit7f8ee9e0beb8a930235bcd93180ccf64d299882f (patch)
tree6fcd736871ea7367cbfde6c53bd3d7a1449095b3
parent37e6965e8954d810738e0b0a86e434ae4e64672b (diff)
downloadguix-7f8ee9e0beb8a930235bcd93180ccf64d299882f.tar
guix-7f8ee9e0beb8a930235bcd93180ccf64d299882f.tar.gz
gnu: sbcl-bordeaux-threads: Adjust threaded tests timeout.
* gnu/packages/lisp-xyz.scm (sbcl-bordeaux-threads)[arguments]: Add phase to slightly lengthen sleep in threaded tests.
-rw-r--r--gnu/packages/lisp-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2170a9e267..95178289c3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018-2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
@@ -442,6 +442,15 @@ timeouts.")
(inputs (list sbcl-alexandria))
(native-inputs (list sbcl-fiveam))
(build-system asdf-build-system/sbcl)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-test-sleep
+ (lambda _
+ ;; 0.001 is too short for some slower machines.
+ (substitute* "test/bordeaux-threads-test.lisp"
+ (("sleep 0\\.001") "sleep 0.002")))))))
(synopsis "Portable shared-state concurrency library for Common Lisp")
(description "BORDEAUX-THREADS is a proposed standard for a minimal
MP/Threading interface. It is similar to the CLIM-SYS threading and lock