aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:04:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:04:48 +0200
commit319aa5fbbcb7d2c4124bab0349254abe711f1124 (patch)
tree3b1ec8633684f650f55d0b965866e8e4e1ec8f86
parentebcf956ec278ebb94e36a57dd5451a63543661f1 (diff)
downloadguix-319aa5fbbcb7d2c4124bab0349254abe711f1124.tar
guix-319aa5fbbcb7d2c4124bab0349254abe711f1124.tar.gz
gnu: Add texlive-pxrubrica.
* gnu/packages/tex.scm (texlive-pxrubrica): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81753a265b..27c7a0cb15 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15199,6 +15199,28 @@ names. This function will assist users who want to use the
@code{japanese-otf} package together with tailored TFMs of Japanese fonts.")
(license license:expat)))
+(define-public texlive-pxrubrica
+ (package
+ (name "texlive-pxrubrica")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/platex/pxrubrica/"
+ "source/platex/pxrubrica/"
+ "tex/platex/pxrubrica/")
+ (base32
+ "0n8jc65szkq114qg197hc9amrpifqvha8wifxplhvbmb09kzm5mm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pxrubrica")
+ (synopsis "Ruby annotations according to JIS X 4051")
+ (description
+ "This package provides a function to add ruby annotations (furigana) that
+follow the style conventional in Japanese typography as described in the W3C
+technical note @emph{Requirements for Japanese Text Layout} and the JIS
+specification JIS X 4051.")
+ (license license:expat)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")