aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-29 15:28:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-30 12:39:33 +0200
commit15dc56b0dd1b30eb60cd716810625409d0208c0f (patch)
treede55e3c54b4053892e4cbb7a3f6ffc061daa29a0
parentf9762c907a65ef0971950c520a4ed798cfedb969 (diff)
downloadguix-15dc56b0dd1b30eb60cd716810625409d0208c0f.tar
guix-15dc56b0dd1b30eb60cd716810625409d0208c0f.tar.gz
gnu: Add r-progressr.
* gnu/packages/cran.scm (r-progressr): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d77161fd6d..3e8b7e3924 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4388,6 +4388,31 @@ acceleration scheme. A tutorial style introduction to this package is
available in a vignette.")
(license license:gpl2+)))
+(define-public r-progressr
+ (package
+ (name "r-progressr")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "progressr" version))
+ (sha256
+ (base32 "03sk5cv8cywahlszjkd8pfqmhbj6cv0j54d3lassa7h44f20zryg"))))
+ (properties `((upstream-name . "progressr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)))
+ (home-page "https://progressr.futureverse.org")
+ (synopsis "Inclusive, unifying API for progress updates")
+ (description
+ "This package provides a minimal, unifying API for scripts and packages
+to report progress updates from anywhere including when using parallel
+processing. The package is designed such that the developer can to focus on
+what progress should be reported on without having to worry about how to
+present it. The end user has full control of how, where, and when to render
+these progress updates.")
+ (license license:gpl3+)))
+
(define-public r-lava
(package
(name "r-lava")