aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:55:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:32 +0200
commit10c387754d3df90dd4c3ce307177d49b2180ffbe (patch)
treed66bc168e6c35b0a09039687505e8abd045632e5
parent2aea0a9bc35e4e5039311571a3e2376427c2dc14 (diff)
downloadguix-10c387754d3df90dd4c3ce307177d49b2180ffbe.tar
guix-10c387754d3df90dd4c3ce307177d49b2180ffbe.tar.gz
gnu: Add texlive-xyling.
* gnu/packages/tex.scm (texlive-xyling): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0ee5f0c758..4942865da3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13045,6 +13045,29 @@ Cyrillic Mongolian using either XeLaTeX or LuaLaTeX. The command
to be able to create multilingual documents.")
(license license:lppl1.3c)))
+(define-public texlive-xyling
+ (package
+ (name "texlive-xyling")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xyling/" "tex/latex/xyling/")
+ (base32
+ "1c4bgkbd42japidvrfg3ibj4h1l8v6zlivy7bqyiyj8alzdjhq4g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xyling")
+ (synopsis
+ "Draw syntactic trees, etc., for linguistics literature, using XY-Pic")
+ (description
+ "The macros in this package model the construction of linguistic tree
+structures as a genuinely graphical problem: they contain two types of
+objects, ``branches'' and ``node labels'', and these are positioned relative
+to a ``grid''. It is essential that each of these three elements is
+constructed independent of the other two, and hence they can be modified
+without unwanted side effects. The macros are based on the XY-Pic package.")
+ (license license:lppl)))
+
(define-public texlive-xymtex
(package
(name "texlive-xymtex")