aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-10-03 11:01:11 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-06 14:19:03 +0200
commitfd0f8860ec667d091abb34f1e4dda4911e834dee (patch)
treeb3fd0531ecf7fff0aa36ea2b46ec11bbeea961fe
parentd3287fc157e98a0f5d13f2e12e06fb8660711e73 (diff)
downloadguix-fd0f8860ec667d091abb34f1e4dda4911e834dee.tar
guix-fd0f8860ec667d091abb34f1e4dda4911e834dee.tar.gz
gnu: ecl: Do not compile the deprecated MIT-RT.
Compiling the rt bundled with ECL prevents the ecl-rt package from compiling properly, as ECL thinks it has already been compiled. * gnu/packages/lisp.scm (ecl)[arguments]: Add '--without-rt' to 'configure-flags'.
-rw-r--r--gnu/packages/lisp.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 80ceb95271..3b810f4093 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -217,7 +217,8 @@ interface to the Tk widget system.")
("libgc" ,libgc)
("libffi" ,libffi)))
(arguments
- '(#:tests? #t
+ '(#:configure-flags '("--without-rt")
+ #:tests? #t
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases