aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-04 12:30:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-05 11:59:49 +0200
commitb5c84b8a37aa268c370ad9c1cf335e5b6c1b3420 (patch)
tree406ca950b2e324b6fbe592a62443538248b8ca71
parentd5e445e1d5b1db458f679f9c37acaf87b922b6cb (diff)
downloadguix-b5c84b8a37aa268c370ad9c1cf335e5b6c1b3420.tar
guix-b5c84b8a37aa268c370ad9c1cf335e5b6c1b3420.tar.gz
gnu: cryptsetup-static: Don't build veritysetup.
* gnu/packages/cryptsetup.scm (cryptsetup-static)[arguments]: Pass ‘--disable-veritysetup’ #:configure-flag. Adjust ‘remove-cruft’ phase.
-rw-r--r--gnu/packages/cryptsetup.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index aae1082a38..8425135245 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,6 +82,8 @@ files). This assumes LIBRARY uses Libtool."
'(#:configure-flags '("--disable-shared"
"--enable-static-cryptsetup"
+ "--disable-veritysetup"
+
;; 'libdevmapper.a' pulls in libpthread, libudev and libm.
"LIBS=-ludev -pthread -lm")
@@ -94,8 +97,7 @@ files). This assumes LIBRARY uses Libtool."
#:phases (modify-phases %standard-phases
(add-after 'install 'remove-cruft
(lambda* (#:key outputs #:allow-other-keys)
- ;; Remove everything except the 'cryptsetup' command and
- ;; its friend.
+ ;; Remove everything except the 'cryptsetup' command.
(let ((out (assoc-ref outputs "out")))
(with-directory-excursion out
(let ((dirs (scandir "."
@@ -109,7 +111,7 @@ files). This assumes LIBRARY uses Libtool."
".static")
file)
(remove-store-references file))
- '("sbin/cryptsetup" "sbin/veritysetup"))
+ '("sbin/cryptsetup"))
#t))))))))
(inputs
(let ((libgcrypt-static