aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-08-08 21:23:50 +0100
committerChristopher Baines <mail@cbaines.net>2019-10-06 19:16:51 +0100
commit803bbd9540fd2837d28f4ac1ad01cadf79a2f7a1 (patch)
tree2ebeb1b878e8b83df401ae201896e62e1a316d5e
parent63b0ce391f6ea79012fac893e933e39d7a16abbd (diff)
downloadguix-803bbd9540fd2837d28f4ac1ad01cadf79a2f7a1.tar
guix-803bbd9540fd2837d28f4ac1ad01cadf79a2f7a1.tar.gz
gnu: Add fifechan.
* gnu/packages/games.scm (fifechan): New variable.
-rw-r--r--gnu/packages/games.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c0d8ce9c71..ebd21fb501 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2027,6 +2027,33 @@ some of the restrictions in the venerable Z-machine format. This is the
reference interpreter, using the Glk API.")
(license license:expat)))
+(define-public fifechan
+ (package
+ (name "fifechan")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://codeload.github.com/fifengine/"
+ "fifechan/tar.gz/" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wxs9vz5x9y8chghd8vp7vfk089lfb0qnzggi17zrqkrngs5zgi9"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("mesa" ,mesa)))
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (home-page "https://fifengine.github.io/fifechan/")
+ (synopsis "Cross platform GUI library specifically for games")
+ (description
+ "Fifechan is a lightweight cross platform GUI library written in C++
+specifically designed for games. It has a built in set of extendable GUI
+Widgets, and allows users to create more.")
+ (license license:lgpl2.1+)))
+
(define-public fizmo
(package
(name "fizmo")