aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:44 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:31:30 +0200
commit5d0059e02efeba259923e02ab7e1bac9ef0210f4 (patch)
tree25360631d1e1618bfd908e7ec3a4c59f00312cbb
parentcd0826d60bcfaba3233c2562776301ae0a65d978 (diff)
downloadguix-5d0059e02efeba259923e02ab7e1bac9ef0210f4.tar
guix-5d0059e02efeba259923e02ab7e1bac9ef0210f4.tar.gz
gnu: Add xfce4-places-plugin.
* gnu/packages/xfce.scm (xfce4-places-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/xfce.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2995d99a48..77a5356466 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1689,6 +1689,48 @@ mounted or when unmounting fails.")
interfaces of your choice in the panel.")
(license gpl2+)))
+(define-public xfce4-places-plugin
+ (package
+ (name "xfce4-places-plugin")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-places-plugin/"
+ (version-major+minor version)
+ "/xfce4-places-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1chac4ki70axgvkmhw94m0srsv0pwiwqrqbh8di0y9n90fgj24gj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gtk+-2" ,gtk+-2)
+ ("exo" ,exo)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin")
+ (synopsis "Gnome-like Places menu for the Xfce panel")
+ (description "This plugin provides a menu with quick access to folders,
+documents, and removable media. The places plugin brings much of the
+functionality of GNOME's Places menu to Xfce.
+
+The plugin puts a simple button on the panel. Clicking on this button
+opens up a menu with the following:
+
+@itemize
+@item System-defined directories (home folder, trash, desktop, file system)
+@item Removable media (using thunar-vfs)
+@item User-defined bookmarks (reads @file{~/.gtk-bookmarks})
+@item Search program launcher (optional)
+@item Recent documents submenu
+@end itemize")
+ (license gpl2+)))
+
(define-public xfce4-smartbookmark-plugin
(package
(name "xfce4-smartbookmark-plugin")