aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-03 15:09:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-03 16:03:36 +0200
commit5767547e7351c761d40bc0af739fcb787e74c16e (patch)
tree53623c0660a73ecf69c1cb51d2ce1a5e72f9fc42
parent3757f5cbc1f5f5b7d49bf8555c0e3bc37f9ae310 (diff)
downloadguix-5767547e7351c761d40bc0af739fcb787e74c16e.tar
guix-5767547e7351c761d40bc0af739fcb787e74c16e.tar.gz
gnu: rcas-web: Fix build with RCAS > 1.3.x.
* gnu/packages/bioinformatics.scm (rcas-web)[arguments]: Add ‘find-RCAS’ phase.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6d36bb73ba..5ec600598b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8418,6 +8418,13 @@ library implementing most of the pipeline's features.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'find-RCAS
+ ;; The configure script can't find non-1.3.x versions of RCAS because
+ ;; its R expression ‘1.10.1 >= 1.3.4’ evaluates to false.
+ (lambda _
+ (substitute* "configure"
+ (("1\\.3\\.4") "0.0.0"))
+ #t))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))