aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortlecarrour@easter-eggs.com <tlecarrour@easter-eggs.com>2019-10-04 09:48:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-10-06 11:46:21 +0300
commit1e8826bdd3103dbe187b2443b2d8ea937cbd1f1c (patch)
tree9503a1bee621d10151a6c10962e2ea0c6e9befe2
parent6792908d6d142e0c97acdf748b5591ca6f18cc0b (diff)
downloadguix-1e8826bdd3103dbe187b2443b2d8ea937cbd1f1c.tar
guix-1e8826bdd3103dbe187b2443b2d8ea937cbd1f1c.tar.gz
gnu: Update python-pastel to 0.1.1.
* gnu/packages/graphics.scm (python-pastel): Update to 0.1.1. [arguments]: Add custom 'check phase. [description]: Simplify description. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/graphics.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6d6c8d1e1c..88bb500450 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -913,28 +914,25 @@ rendering SVG graphics.")
(define-public python-pastel
(package
(name "python-pastel")
- (version "0.1.0")
+ (version "0.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pastel" version))
(sha256
(base32
- "1hqbm934n5yjwn31aq8h7shrr0rcy326wrqfc856vyn0gr0sy21i"))))
+ "1qxcrcl8pzh66l8s6hym153mijdhwna0afcsmgca0bj4n80ijfxz"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "pytest" "pastel" "tests/"))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/sdispater/pastel")
(synopsis "Library to colorize strings in your terminal")
(description "Pastel is a simple library to help you colorize strings in
-your terminal. It comes bundled with predefined styles:
-@enumerate
-@item info: green
-@item comment: yellow
-@item question: black on cyan
-@item error: white on red
-@end enumerate
-")
+your terminal.")
(license license:expat)))
(define-public python2-pastel