aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-08-08 20:57:27 +0100
committerChristopher Baines <mail@cbaines.net>2019-08-08 20:57:27 +0100
commite053e5fc4cfd9a1b21c289a5e7ca7aeea7358b30 (patch)
treeef6bd79c2a347a2f8a69786489ec68456c695707
parent5cded306f92a8641259909ee986e583168b85b17 (diff)
downloadguix-e053e5fc4cfd9a1b21c289a5e7ca7aeea7358b30.tar
guix-e053e5fc4cfd9a1b21c289a5e7ca7aeea7358b30.tar.gz
gnu: Add fifechan.
* gnu/packages/games.scm (fifechan): New variable.
-rw-r--r--gnu/packages/games.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 92df556970..8ee0ef94b3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2033,6 +2033,33 @@ some of the restrictions in the venerable Z-machine format. This is the
reference interpreter, using the Glk API.")
(license license:expat)))
+(define-public fifechan
+ (package
+ (name "fifechan")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://codeload.github.com/fifengine/"
+ "fifechan/tar.gz/" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wxs9vz5x9y8chghd8vp7vfk089lfb0qnzggi17zrqkrngs5zgi9"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("mesa" ,mesa)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://fifengine.github.io/fifechan/")
+ (synopsis "Cross platform GUI library designed for games")
+ (description
+ "Fifechan is a lightweight cross platform GUI library written in C++
+specifically designed for games. It has a built in set of extendable GUI
+Widgets, and allows users to create more.")
+ (license license:lgpl2.1+)))
+
(define-public fizmo
(package
(name "fizmo")