aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 10:45:46 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:31 -0400
commitb57e99f574c9496cd40fba1e9a9f1e84885ad2d5 (patch)
tree5306b387b6b0ad4af2d37d542940c9c27ba8fa55
parentefb96749a2af02d59f341db033e87082f9289705 (diff)
downloadguix-b57e99f574c9496cd40fba1e9a9f1e84885ad2d5.tar
guix-b57e99f574c9496cd40fba1e9a9f1e84885ad2d5.tar.gz
gnu: Add ghc-readable.
* gnu/packages/haskell-xyz.scm (ghc-readable): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a03ea4c88c..8291c7f083 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -120,3 +120,23 @@ to @code{Show}, based on the HughesPJ pretty printing library. It
provides the pretty printing class and instances for the Prelude
types.")
(license license:bsd-3)))
+
+(define-public ghc-readable
+ (package
+ (name "ghc-readable")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "readable/readable-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ja39cg26wy2fs00gi12x7iq5k8i366pbqi3p916skfa5jnkfc3h"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/mightybyte/readable")
+ (synopsis "Type class for reading from Text and ByteString")
+ (description "This package provides a @code{Readable} type class for
+reading data types from @code{ByteString} and @code{Text}. It also
+includes efficient implementations for common data types.")
+ (license license:bsd-3)))