aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-18 19:26:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-08-08 15:18:30 +0300
commit8cd51276e53fc4988029bcd2de2b69db68ea6e05 (patch)
treef12ba38f2b06fe38bdba8a93d488c6fa9f6c17cc
parent7faa70cf2b6a81f2670b52e5caa502e409626faa (diff)
downloadguix-8cd51276e53fc4988029bcd2de2b69db68ea6e05.tar
guix-8cd51276e53fc4988029bcd2de2b69db68ea6e05.tar.gz
gnu: Add multichoose.
* gnu/packages/bioinformatics.scm (multichoose): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2105393473..086e9324cb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14898,3 +14898,37 @@ some of the details of opening and jumping in tabix-indexed files.")
(description "Implementation of the Smith-Waterman algorithm.")
;; The licensing terms are unclear: https://github.com/ekg/smithwaterman/issues/9.
(license (list license:gpl2 license:expat)))))
+
+(define-public multichoose
+ (package
+ (name "multichoose")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekg/multichoose/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ci5fqvmpamwgxvmyd79ygj6n3bnbl3vc7b6h1sxz58186sm3pfs"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; Tests require node.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ ;; TODO: There are Python modules for these programs too.
+ (install-file "multichoose" bin)
+ (install-file "multipermute" bin))
+ #t)))))
+ (home-page "https://github.com/ekg/multichoose")
+ (synopsis "Efficient loopless multiset combination generation algorithm")
+ (description "This library implements an efficient loopless multiset
+combination generation algorithm which is (approximately) described in
+\"Loopless algorithms for generating permutations, combinations, and other
+combinatorial configurations.\", G. Ehrlich - Journal of the ACM (JACM),
+1973. (Algorithm 7.)")
+ (license license:expat)))