aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-18 19:26:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-08-08 15:18:29 +0300
commit7faa70cf2b6a81f2670b52e5caa502e409626faa (patch)
tree6f983d553ac6342c2ded9439e731ff7ccd2f2eae
parent62a031afc438dcf2c2b38259334cb6e3b369a908 (diff)
downloadguix-7faa70cf2b6a81f2670b52e5caa502e409626faa.tar
guix-7faa70cf2b6a81f2670b52e5caa502e409626faa.tar.gz
gnu: Add smithwaterman.
* gnu/packages/bioinformatics.scm (smithwaterman): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5a63399967..2105393473 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14867,3 +14867,34 @@ mutations from scRNA-Seq data.")
(description "This is a C++ wrapper around the Tabix project which abstracts
some of the details of opening and jumping in tabix-indexed files.")
(license license:expat)))
+
+(define-public smithwaterman
+ ;; TODO: Upgrading smithwaterman breaks FreeBayes.
+ (let ((commit "203218b47d45ac56ef234716f1bd4c741b289be1"))
+ (package
+ (name "smithwaterman")
+ (version (string-append "0-1." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekg/smithwaterman/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z9xsmsv452kgdfbbwydyc6nymg3fwyv8zswls8qjin3r4ia4415"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "smithwaterman" bin))
+ #t)))))
+ (home-page "https://github.com/ekg/smithwaterman")
+ (synopsis "Implementation of the Smith-Waterman algorithm")
+ (description "Implementation of the Smith-Waterman algorithm.")
+ ;; The licensing terms are unclear: https://github.com/ekg/smithwaterman/issues/9.
+ (license (list license:gpl2 license:expat)))))