aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 10:43:55 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:30 -0400
commit79fcc5e59bc8cd6726937be291964477fe673e3a (patch)
tree9aded831b2e1ae04f3fb784ee171791772eef3ff
parent6b34d01cbf475f44b2fbe59033798b2b1d7a5417 (diff)
downloadguix-79fcc5e59bc8cd6726937be291964477fe673e3a.tar
guix-79fcc5e59bc8cd6726937be291964477fe673e3a.tar.gz
gnu: Add ghc-language-glsl.
* gnu/packages/haskell-xyz.scm (ghc-language-glsl): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fbd40cd3ac..17736c9365 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -23,6 +23,30 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages))
+(define-public ghc-language-glsl
+ (package
+ (name "ghc-language-glsl")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "language-glsl/language-glsl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hdg67ainlqpjjghg3qin6fg4p783m0zmjqh4rd5gyizwiplxkp1"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-prettyclass" ,ghc-prettyclass)))
+ (arguments
+ `(#:tests? #f
+ #:cabal-revision
+ ("1" "10ac9pk4jy75k03j1ns4b5136l4kw8krr2d2nw2fdmpm5jzyghc5")))
+ (home-page "http://hackage.haskell.org/package/language-glsl")
+ (synopsis "GLSL abstract syntax tree, parser, and pretty-printer")
+ (description "This package is a Haskell library for the
+representation, parsing, and pretty-printing of GLSL 1.50 code.")
+ (license license:bsd-3)))
+
(define-public ghc-prettyclass
(package
(name "ghc-prettyclass")