aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 10:48:35 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:31 -0400
commit658dbc7ff2f39053511725fa149df7029fae1141 (patch)
tree05bea4a1bfef490876a5400fd2f47a85820c4e13
parent14e41996462776cffaad3cb355e817c1631ce5c5 (diff)
downloadguix-658dbc7ff2f39053511725fa149df7029fae1141.tar
guix-658dbc7ff2f39053511725fa149df7029fae1141.tar.gz
gnu: Add ghc-io-streams.
* gnu/packages/haskell-xyz.scm (ghc-io-streams): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7ccbae1443..592296ded8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -76,6 +76,42 @@ This package was inspired by the concurrency libraries of Java and
Python.")
(license license:bsd-3)))
+(define-public ghc-io-streams
+ (package
+ (name "ghc-io-streams")
+ (version "1.5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "io-streams/io-streams-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12rcdg2d70644bvn838fxcjkssqj8pssnx5y657si5rijcbkgjsx"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-bytestring-builder" ,ghc-bytestring-builder)
+ ("ghc-network" ,ghc-network)
+ ("ghc-primitive" ,ghc-primitive)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-zlib-bindings" ,ghc-zlib-bindings)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-zlib" ,ghc-zlib)))
+ (arguments
+ `(#:cabal-revision
+ ("2" "1mcab95d6hm098myh9gp7sh10srigjphgvm8s9pfs7jg5hzghy14")))
+ (home-page "http://hackage.haskell.org/package/io-streams")
+ (synopsis "Simple and composable stream I/O")
+ (description "This library contains simple and easy-to-use
+primitives for I/O using streams.")
+ (license license:bsd-3)))
+
(define-public ghc-language-glsl
(package
(name "ghc-language-glsl")