aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 10:47:41 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:31 -0400
commit14e41996462776cffaad3cb355e817c1631ce5c5 (patch)
tree0ea9429fd5cb528baaaf4217cfd509a3bb86139f
parentbbf8bf31e4654f8e8ac83fd454183e6304044936 (diff)
downloadguix-14e41996462776cffaad3cb355e817c1631ce5c5.tar
guix-14e41996462776cffaad3cb355e817c1631ce5c5.tar.gz
gnu: Add ghc-zlib-bindings.
* gnu/packages/haskell-xyz.scm (ghc-zlib-bindings): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8dc16f685b..7ccbae1443 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -177,3 +177,30 @@ package is similar to the @code{threadmanager}, @code{async} and
@code{forkIOWithUnmask}.
@end itemize")
(license license:bsd-3)))
+
+(define-public ghc-zlib-bindings
+ (package
+ (name "ghc-zlib-bindings")
+ (version "0.1.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "zlib-bindings/zlib-bindings-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02ciywlz4wdlymgc3jsnicz9kzvymjw1www2163gxidnz4wb8fy8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-zlib" ,ghc-zlib)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (arguments
+ `(#:cabal-revision
+ ("2" "0fq49694gqkab8m0vq4i879blswczwd66n7xh4r4gwiahf0ryvqc")))
+ (home-page "https://github.com/snapframework/zlib-bindings")
+ (synopsis "Low-level bindings to the @code{zlib} package")
+ (description "This package provides low-level bindings to the
+@code{zlib} package.")
+ (license license:bsd-3)))