aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-26 04:31:44 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:18 +0200
commitfa71034115cc43b2bfcadaa57fff51c6319f9d2f (patch)
tree5a51dfc8781e6fd3608cd7615a2515fee70aeceb
parent8330715878d6387a6c5c87adcee2f181dc36c117 (diff)
downloadguix-fa71034115cc43b2bfcadaa57fff51c6319f9d2f.tar
guix-fa71034115cc43b2bfcadaa57fff51c6319f9d2f.tar.gz
gnu: emacs-disk-usage: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-disk-usage)[source]: Use GIT-FETCH and GIT-FILE-NAME. [home-page] Move to usual location. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 489e2ce14e..1f32ee27d2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14915,18 +14915,18 @@ opposed to character-based).")
(package
(name "emacs-disk-usage")
(version "1.3.3")
- (home-page "https://gitlab.com/Ambrevar/emacs-disk-usage")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://elpa.gnu.org/packages/disk-usage-"
- version
- ".el"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/Ambrevar/emacs-disk-usage.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0h1jwznd41gi0vg830ilfgm01q05zknikzahwasm9cizwm2wyizj"))))
+ "0hv2gsd8k5fbjgckgiyisq4rn1i7y4rchbjy8kmixjv6mx563bll"))))
(build-system emacs-build-system)
+ (home-page "https://gitlab.com/Ambrevar/emacs-disk-usage")
(synopsis "Sort and browse disk usage listings with Emacs")
(description "Disk Usage is a file system analyzer: it offers a tabulated
view of file listings sorted by size. Directory sizes are computed