aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-13 16:06:26 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:20 +0200
commitf1122a2c91d4c6f5bdda495882ac6c9efc4843a8 (patch)
treef899ffa8ad6245ff34e59bf5631f56ab00b641a1
parent9b2850c8458747d6840538b1cf9a7f8b804bf17b (diff)
downloadguix-f1122a2c91d4c6f5bdda495882ac6c9efc4843a8.tar
guix-f1122a2c91d4c6f5bdda495882ac6c9efc4843a8.tar.gz
gnu: Add python-agate-dbf.
* gnu/packages/wireservice.scm (python-agate-dbf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wireservice.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index 575b63792b..4a8e7681ed 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -146,3 +146,25 @@ code. Agate was previously known as journalism.")))
(synopsis "SQL read/write support to agate")
(description "@code{agatesql} uses a monkey patching pattern to add SQL
support to all @code{agate.Table} instances.")))
+
+(define-public python-agate-dbf
+ (package
+ (inherit base-package)
+ (name "python-agate-dbf")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wireservice/agate-dbf.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y49fi6pmm7gzhajvqmfpcca2sqnwj24fqnsvzwk7r1hg2iaa2gi"))))
+ (propagated-inputs
+ `(("python-agate" ,python-agate)
+ ("python-dbfread" ,python-dbfread)))
+ (home-page "https://agate-dbf.rtfd.org")
+ (synopsis "Add read support for dbf files to agate")
+ (description "@code{agatedbf} uses a monkey patching pattern to add read
+for dbf files support to all @code{agate.Table} instances.")))