aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-07-05 22:29:12 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-05 22:29:12 +0200
commit6b4a4318434522372a5f2c7476fbc1bacbcee278 (patch)
tree5bf72739f39100ca9e644b282150aa1ea61599c9
parent1aa026aa397e12305cad0ed4fd50c2257e760c4a (diff)
downloadguix-6b4a4318434522372a5f2c7476fbc1bacbcee278.tar
guix-6b4a4318434522372a5f2c7476fbc1bacbcee278.tar.gz
Revert "gnu: Add sbcl-dbus."
Remove sbcl-dbus because it depends on sbcl-cl-xmlspam, which is currently non-free. This reverts commit 7af213fefe3608a80c9f0a7e91f0c79051aff16f.
-rw-r--r--gnu/packages/lisp.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index c05ec715cb..64e5a16939 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6608,39 +6608,3 @@ also makes it easy to shift paradigms when necessary - the usual Lisp control
constructs can be used interchangeably with pattern matching, and the full
power of CXML is available when necessary.")
(license #f)))
-
-(define-public sbcl-dbus
- (let ((commit "24b452df3a45ca5dc95015500f34baad175c981a")
- (revision "1"))
- (package
- (name "sbcl-dbus")
- (build-system asdf-build-system/sbcl)
- (version (git-version "20190408" revision commit))
- (home-page "https://github.com/death/dbus")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("trivial-garbage" ,sbcl-trivial-garbage)
- ("babel" ,sbcl-babel)
- ("iolib" ,sbcl-iolib)
- ("iolib+multiplex" ,sbcl-iolib+multiplex)
- ("iolib+syscalls" ,sbcl-iolib+syscalls)
- ("iolib+streams" ,sbcl-iolib+streams)
- ("iolib+sockets" ,sbcl-iolib+sockets)
- ("ieee-floats" ,sbcl-ieee-floats)
- ("flexi-streams" ,sbcl-flexi-streams)
- ("cl-xmlspam" ,sbcl-cl-xmlspam)
- ("ironclad" ,sbcl-ironclad)))
- (synopsis "D-Bus client library for Common Lisp")
- (description "This is a Common Lisp library that allows to publish D-Bus
-objects as well as send and notify other objects connected to a bus.")
- (license license:bsd-2))))