aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>2019-07-05 14:56:07 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2019-07-06 02:10:04 -0400
commit5cbb832fb107a8ca55938a52f6699ad8c6f08c8d (patch)
tree25ed88c8444de3cfe08abe4073bcba8f1eaa9eda
parentfa9edf09e992db7510c7471486dffc93e1e707e5 (diff)
downloadguix-5cbb832fb107a8ca55938a52f6699ad8c6f08c8d.tar
guix-5cbb832fb107a8ca55938a52f6699ad8c6f08c8d.tar.gz
Add 'guix deploy'.
* guix/scripts/deploy.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--guix/scripts/deploy.scm84
-rw-r--r--po/guix/POTFILES.in1
3 files changed, 86 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index beb60097a4..34bef76b47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -267,6 +267,7 @@ MODULES = \
guix/scripts/weather.scm \
guix/scripts/container.scm \
guix/scripts/container/exec.scm \
+ guix/scripts/deploy.scm \
guix.scm \
$(GNU_SYSTEM_MODULES)
diff --git a/guix/scripts/deploy.scm b/guix/scripts/deploy.scm
new file mode 100644
index 0000000000..978cfb2a81
--- /dev/null
+++ b/guix/scripts/deploy.scm
@@ -0,0 +1,84 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 David Thompson <davet@gnu.org>
+;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts deploy)
+ #:use-module (gnu machine)
+ #:use-module (guix scripts)
+ #:use-module (guix scripts build)
+ #:use-module (guix store)
+ #:use-module (guix ui)
+ #:use-module (ice-9 format)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-37)
+ #:export (guix-deploy))
+
+;;; Commentary:
+;;;
+;;; This program provides a command-line interface to (gnu machine), allowing
+;;; users to perform remote deployments through specification files.
+;;;
+;;; Code:
+
+
+
+(define (show-help)
+ (display (G_ "Usage: guix deploy [OPTION] FILE...
+Perform the deployment specified by FILE.\n"))
+ (show-build-options-help)
+ (newline)
+ (display (G_ "
+ -h, --help display this help and exit"))
+ (display (G_ "
+ -V, --version display version information and exit"))
+ (newline)
+ (show-bug-report-information))
+
+(define %options
+ (cons* (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ %standard-build-options))
+
+(define %default-options
+ '((system . ,(%current-system))
+ (substitutes? . #t)
+ (build-hook? . #t)
+ (graft? . #t)
+ (debug . 0)
+ (verbosity . 1)))
+
+(define (load-source-file file)
+ "Load FILE as a user module."
+ (let ((module (make-user-module '((gnu) (gnu machine) (gnu machine ssh)))))
+ (load* file module)))
+
+(define (guix-deploy . args)
+ (define (handle-argument arg result)
+ (alist-cons 'file arg result))
+ (let* ((opts (parse-command-line args %options (list %default-options)
+ #:argument-handler handle-argument))
+ (file (assq-ref opts 'file))
+ (machines (or (and file (load-source-file file)) '())))
+ (with-store store
+ (set-build-options-from-command-line store opts)
+ (for-each (lambda (machine)
+ (info (G_ "deploying to ~a...") (machine-display-name machine))
+ (run-with-store store (deploy-machine machine)))
+ machines))))
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index bcd6f76371..f5fc4956b4 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -67,6 +67,7 @@ guix/scripts/pack.scm
guix/scripts/weather.scm
guix/scripts/describe.scm
guix/scripts/processes.scm
+guix/scripts/deploy.scm
guix/gnu-maintenance.scm
guix/scripts/container.scm
guix/scripts/container/exec.scm