aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-13 16:06:23 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:20 +0200
commit451742bcf658b0bc185e925d01d5b96355bda412 (patch)
tree9758748df3c76c9e7e93015582ee3fda25d8832e
parentedeb04bfb78524e46f5e20fcef5bb025469e216c (diff)
downloadguix-451742bcf658b0bc185e925d01d5b96355bda412.tar
guix-451742bcf658b0bc185e925d01d5b96355bda412.tar.gz
gnu: Add python-leather.
* gnu/packages/wireservice.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/wireservice.scm91
2 files changed, 92 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f6392ccd23..0f4c1ce5c8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -490,6 +490,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/wget.scm \
%D%/packages/wicd.scm \
%D%/packages/wine.scm \
+ %D%/packages/wireservice.scm \
%D%/packages/wm.scm \
%D%/packages/wordnet.scm \
%D%/packages/wv.scm \
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
new file mode 100644
index 0000000000..290b027e7b
--- /dev/null
+++ b/gnu/packages/wireservice.scm
@@ -0,0 +1,91 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages wireservice)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system python)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx))
+
+;; Base package definition for packages from https://github.com/wireservice.
+;; This is done so we can share how to run tests and build documentation.
+(define base-package
+ (package
+ (name #f)
+ (version #f)
+ (source #f)
+ (home-page #f)
+ (synopsis #f)
+ (description #f)
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-sphinx" ,python-sphinx)
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "nosetests" "tests")))
+ (add-after 'install 'install-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/"
+ ,(package-name this-package)
+ "-"
+ ,(package-version this-package))))
+ (with-directory-excursion "docs"
+ (for-each
+ (lambda (target)
+ (invoke "make" target)
+ (copy-recursively (string-append "_build/" target)
+ (string-append doc "/" target)))
+ '("html" "dirhtml" "singlehtml" "text")))
+ #t))))))
+ (license license:expat)))
+
+(define-public python-leather
+ (package
+ (inherit base-package)
+ (name "python-leather")
+ (version "0.3.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wireservice/leather.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ck3dplni99sv4s117cbm07ydwwjsrxkhdy19rnk0iglia1d4s5i"))))
+ (native-inputs
+ `(("python-cssselect" ,python-cssselect)
+ ("python-lxml" ,python-lxml)
+ ,@(package-native-inputs base-package)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://leather.rtfd.org")
+ (synopsis "Python charting for 80% of humans")
+ (description "Leather is a Python charting library for those who need
+charts now and don't care if they're perfect.")))