aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-20 13:42:53 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-22 09:53:24 +0800
commitfeaae484998233fca1ec57ca50ea8225221b1815 (patch)
tree4b7780751ec1533f6492e8d8f82b46a521487e24
parentaad8877d914b8dceb0c561d1e8d2b503731aad9a (diff)
downloadguix-feaae484998233fca1ec57ca50ea8225221b1815.tar
guix-feaae484998233fca1ec57ca50ea8225221b1815.tar.gz
gnu: Add python-waf.
* gnu/packages/python.scm (python-waf, python2-waf): New variables.
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d64f6331d9..050c0de402 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3508,3 +3508,39 @@ It is written entirely in Python.")
(define-public python2-singledispatch
(package-with-python2 python-singledispatch))
+
+(define-public python-waf
+ (package
+ (name "python-waf")
+ (version "1.8.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://waf.io/"
+ "waf-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0b5q307fgn6a5d8yjia2d1l4bk1q3ilvc0w8k4isfrrx2gbcw8wn"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero? (begin
+ (system* "python" "waf-light" "configure")
+ (system* "python" "waf-light" "build")))))
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "waf" "--version"))))
+ (replace 'install
+ (lambda _
+ (copy-file "waf" %output))))))
+ (home-page "https://waf.io/")
+ (synopsis "Python-based build system")
+ (description
+ "Waf is a Python-based framework for configuring, compiling and installing
+applications.")
+ (license bsd-3)))
+
+(define-public python2-waf
+ (package-with-python2 python-waf))