aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-02 22:25:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-10-03 10:26:42 +0300
commitf64c80a53843006aa96bbdb3d5286f67c7dc8d8f (patch)
tree5801cd2837abb3c50a65c4806b18938ce4ff9253
parent3fbe68d9fc700657c57989b7f505bb4fced299de (diff)
downloadguix-f64c80a53843006aa96bbdb3d5286f67c7dc8d8f.tar
guix-f64c80a53843006aa96bbdb3d5286f67c7dc8d8f.tar.gz
gnu: emacs-ag: Do not propagate the-silver-searcher.
* gnu/packages/emacs-xyz.scm (emacs-ag)[phases]: Add phase substitute-ag-path to avoid propagating ag. [inputs]: Add the-silver-searcher. [propagated-inputs]: Remove the-silver-searcher. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f93c5abf9a..0cd9fa1959 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3029,6 +3029,11 @@ links.")
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'substitute-ag-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "ag.el")
+ (emacs-substitute-variables "ag.el"
+ ("ag-executable" (search-input-file inputs "/bin/ag")))))
(add-before 'install 'make-info
(lambda _
(with-directory-excursion "docs"
@@ -3037,12 +3042,11 @@ links.")
(lambda _
(install-file "docs/_build/texinfo/agel.info"
(string-append #$output "/share/info")))))))
+ (inputs (list the-silver-searcher)) ; 'ag' executable
(native-inputs
(list python-sphinx texinfo))
(propagated-inputs
- (list emacs-dash
- emacs-s
- the-silver-searcher)) ;'ag' executable
+ (list emacs-dash emacs-s))
(home-page "https://github.com/Wilfred/ag.el")
(synopsis "Front-end for ag (the-silver-searcher) for Emacs")
(description "This package provides the ability to use the silver