aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-24 14:42:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-24 17:51:28 +0100
commiteea4a0910c8f09f383a5314ce08609a95969d783 (patch)
tree575b8b643c7a38f7cf05f40d21b8b7b3f03d07e1
parentd9c8009832077cc01412f379bb5f39e43d5a18d2 (diff)
downloadguix-eea4a0910c8f09f383a5314ce08609a95969d783.tar
guix-eea4a0910c8f09f383a5314ce08609a95969d783.tar.gz
gnu: 4ti2: Update to 1.6.9.
* gnu/packages/maths.scm (4ti2): Update to 1.6.9. [source]: Update URI.
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bf03571c45..74554e2d49 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -428,15 +428,17 @@ LP/MIP solver is included in the package.")
(define-public 4ti2
(package
(name "4ti2")
- (version "1.6.7")
+ (version "1.6.9")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.4ti2.de/version_" version
- "/4ti2-" version ".tar.gz"))
- (sha256
- (base32
- "1frix3rnm9ffr93alqzw4cavxbfpf524l8rfbmcpyhwd3n1km0yl"))))
+ (method url-fetch)
+ (uri (string-append "https://github.com/4ti2/4ti2/releases/download/"
+ "Release_"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c))
+ version)
+ "/4ti2-" version ".tar.gz"))
+ (sha256
+ (base32 "0rj92x6p9m3la5gasjbj7sa569im527ffmka5y2sv1amgd3fflrh"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,(@ (gnu packages base) which)))) ; for the tests