aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-04 13:31:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-04 13:37:42 +0200
commitdf5a021f66a2f39bd0be2b488fb797773b5275d9 (patch)
treedd36d6e6aee953949db9a3a1e892f07f256d09ad
parent5e8221822e2841f1bd325f4a783c9131910af17d (diff)
downloadguix-df5a021f66a2f39bd0be2b488fb797773b5275d9.tar
guix-df5a021f66a2f39bd0be2b488fb797773b5275d9.tar.gz
gnu: emacs-modus-themes: Update to 2.7.1.
* gnu/packages/emacs-xyz.scm (emacs-modus-themes): Update to 2.7.1.
-rw-r--r--gnu/packages/emacs-xyz.scm67
1 files changed, 35 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db2323efb3..48d4e05bfc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29398,36 +29398,39 @@ Emacs that integrate with major modes like Org-mode.")
(license license:expat)))
(define-public emacs-modus-themes
- (package
- (name "emacs-modus-themes")
- (version "2.6.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~protesilaos/modus-themes")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1zl1gd3jlkanjmlsxmwhqaiwyblp6kzznfjnw9cq8ah2390y9n1c"))))
- (native-inputs (list texinfo))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda _
- (invoke "emacs"
- "--batch"
- "--eval=(require 'ox-texinfo)"
- "--eval=(find-file \"doc/modus-themes.org\")"
- "--eval=(org-texinfo-export-to-info)")
- (install-file "doc/modus-themes.info" (string-append #$output "/share/info")))))))
- (home-page "https://protesilaos.com/modus-themes/")
- (synopsis "Accessible themes (WCAG AAA)")
- (description
- "The Modus themes are designed for accessible readability. They conform
+ ;; XXX: Upstream did not tag latest version bump, so we use the commit
+ ;; matching that bump.
+ (let ((commit "0b42e595fb8c1753039277ab0b068d0f4f107edf"))
+ (package
+ (name "emacs-modus-themes")
+ (version "2.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/modus-themes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iy1psfkhqf9a47pabl1w108niw2d4xnfvlcql2j58qlv5k9h1z7"))))
+ (native-inputs (list texinfo))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"doc/modus-themes.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "doc/modus-themes.info" (string-append #$output "/share/info")))))))
+ (home-page "https://protesilaos.com/modus-themes/")
+ (synopsis "Accessible themes (WCAG AAA)")
+ (description
+ "The Modus themes are designed for accessible readability. They conform
with the highest standard for color contrast between any given combination of
background and foreground values. This corresponds to the WCAG AAA standard,
which specifies a minimum rate of distance in relative luminance of 7:1.
@@ -29436,8 +29439,8 @@ Modus Operandi (modus-operandi) is a light theme, while Modus
Vivendi (modus-vivendi) is dark. Each theme’s color palette is designed to
meet the needs of the numerous interfaces that are possible in the Emacs
computing environment.")
- (license (list license:gpl3+
- license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+ (license (list license:gpl3+
+ license:fdl1.3+))))) ; GFDLv1.3+ for the manual
(define-public emacs-punpun-theme
(let ((commit "7026684cd568cb691af3ced5de14c375fe6f5a1a")