aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@using.tech>2022-09-29 17:12:20 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-30 12:54:00 +0200
commitdf485be2f7d939b5c2b83a3a467cdff4d5a93851 (patch)
treee891867f46cfbe4e080e8f2f3c660d1bb2b72202
parentbcf7dc6c56c35e8e11e56215b3d32a08c42269d3 (diff)
downloadguix-df485be2f7d939b5c2b83a3a467cdff4d5a93851.tar
guix-df485be2f7d939b5c2b83a3a467cdff4d5a93851.tar.gz
gnu: Add qdmr.
* gnu/packages/radio.scm (qdmr): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/radio.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 2968f9d390..fcf69b0e87 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Sheng Yang <styang@fastmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 Ryan Tolboom <ryan@using.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,6 +90,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
@@ -2668,3 +2670,40 @@ the navigation message, computation of observables and, finally, computation of
position fixes) the signals of the BeiDou, Galileo, GLONASS and GPS Global
Navigation Satellite System.")
(license license:gpl3+)))
+
+(define-public qdmr
+ (package
+ (name "qdmr")
+ (version "0.10.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hmatuschek/qdmr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "037vkwk974zrwacxafslkb3mbw9258v9sdpwdvb23msjzbc3snrn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "lib/CMakeLists.txt"
+ (("(DESTINATION \")/etc/udev/" _ directive)
+ (string-append directive #$output "/lib/udev/"))))))))
+ (inputs (list libusb qtbase-5 qtlocation qtserialport yaml-cpp))
+ (native-inputs (list qttools-5))
+ (home-page "https://dm3mat.darc.de/qdmr/")
+ (synopsis "GUI application and command line tool to program DMR radios")
+ (description
+ "qdmr is a graphical user interface (GUI) application that allows one to
+program several types of DMR radios. It is comparable to the Customer
+Programming Software (CPS) bundled with these radios but aims to be a more
+universal tool.
+
+To install the qdmr udev rules, you must extend @code{udev-service-type} with this
+package. E.g.: @code{(udev-rules-service 'qdmr qdmr)}")
+ (license license:gpl3+)))