aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-05 12:24:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commitd0e4378266681c294754bb09ad8cfe810ffdb29e (patch)
treeca27505cbb6abba4ad16b7459f2e30e2114d4519
parent0c5d837c8238b850cbd1d9a97dfbdd2b1a2cdbae (diff)
downloadguix-d0e4378266681c294754bb09ad8cfe810ffdb29e.tar
guix-d0e4378266681c294754bb09ad8cfe810ffdb29e.tar.gz
gnu: Add emacs-expand-region.
* gnu/packages/emacs.scm (emacs-expand-region): New variable.
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fb84d90c1e..371c3fae40 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1329,6 +1329,28 @@ Expectations, but it can be used in other contexts.")
definitions for testing with the Ecukes framework.")
(license license:gpl3+)))
+(define-public emacs-expand-region
+ (package
+ (name "emacs-expand-region")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/magnars/expand-region.el"
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zfiaqyb3zqiyqjkpqsjw660j09805nqsg25q6ars2h8gs0rnvxb"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/magnars/expand-region.el")
+ (synopsis "Increase selected region by semantic units")
+ (description
+ "Expand region increases the selected region by semantic units. Just
+keep pressing the key until it selects what you want. There's also
+@code{er/contract-region} if you expand too far.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")