aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2022-09-30 20:38:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-04 13:37:43 +0200
commitba84c8c4489e0b22fc692724416829c377b4ee91 (patch)
tree341556a8b4591ee6d5533d9edee58807c1e27f44
parent31e19fd874cb1e3ccccd9d2d0bb5e4fcc5dd4e23 (diff)
downloadguix-ba84c8c4489e0b22fc692724416829c377b4ee91.tar
guix-ba84c8c4489e0b22fc692724416829c377b4ee91.tar.gz
gnu: augustus: Update to 3.2.0.
* gnu/packages/games.scm (augustus): Update to 3.2.0. [inputs]: Add expat. [snippet]: Unbundle it. Drop trailing #t. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/games.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8d569b013f..65375c9acc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1589,7 +1589,7 @@ does not include game data.")
(package
(inherit julius)
(name "augustus")
- (version "2.0.1")
+ (version "3.2.0")
(source
(origin
(method git-fetch)
@@ -1598,17 +1598,19 @@ does not include game data.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0czazw8mc3fbvdazs2nzvgxd1dpzjc8z5fwiv89vv4nd7laz3jkj"))
+ (base32 "0d1k5279imc17mk3lxn8amc4ljgcj4v6x6lj2w3bph1z0a7a4bim"))
;; Remove unused bundled libraries.
(modules '((guix build utils)))
(snippet
'(begin
(with-directory-excursion "ext"
- (for-each delete-file-recursively '("dirent" "png" "SDL2" "zlib")))
- #t))))
+ (for-each delete-file-recursively
+ '("dirent" "expat" "png" "SDL2" "zlib")))))))
(arguments
;; No tests. See https://github.com/Keriew/augustus/issues/82.
`(#:tests? #f))
+ (inputs (modify-inputs (package-inputs julius)
+ (prepend expat)))
(home-page "https://github.com/Keriew/augustus")
(synopsis "Re-implementation of Caesar III game engine with gameplay changes")
(description