aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-22 16:59:10 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:20:05 +0200
commitb479089fdc64271c40f83084970d92bb64280edc (patch)
tree2ffb5f7f9ead02fa6d8a274d5c6a05e3abca0a1d
parent69aa41e405ebc1ace2bc7d57127e320e42ba0dc0 (diff)
downloadguix-b479089fdc64271c40f83084970d92bb64280edc.tar
guix-b479089fdc64271c40f83084970d92bb64280edc.tar.gz
gnu: Add texlive-generic-xstring.
* gnu/packages/tex.scm (texlive-generic-xstring): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e5e7921ad7..1266d46861 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11877,6 +11877,27 @@ syllable. The package itself does not support UTF-8 input in ordinary
(PDF)LaTeX; some UTF-8 support is offered by package @code{soulutf8}.")
(license license:lppl))))
+(define-public texlive-generic-xstring
+ (let ((template (simple-texlive-package
+ "texlive-generic-xstring"
+ (list "/doc/generic/xstring/"
+ "/tex/generic/xstring/")
+ (base32
+ "1azpq855kq1l4686bjp8haxim5c8wycz1b6lcg5q7x8kb4g9sppn")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/xstring")
+ (synopsis "String manipulation for (La)TeX")
+ (description
+ "@code{xstring} package provides macros for manipulating strings --
+testing a string's contents, extracting substrings, substitution of substrings
+and providing numbers such as string length, position of, or number of
+recurrences of, a substring. The package works equally in Plain TeX and LaTeX
+(though e-TeX is always required). The strings to be processed may contain
+(expandable) macros.")
+ (license license:lppl1.3c))))
+
(define-public texlive-latex-totcount
(package
(inherit (simple-texlive-package