aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-07-14 17:07:25 +0200
committerAndreas Enge <andreas@enge.fr>2016-07-15 14:31:37 +0200
commit7fb18f578aa06be524f7b06ba36aab18b1a82cb8 (patch)
tree54ffa4a47696c2b9e884459885f469e6c768fb58
parente05647add7d4ebddf68626b84fa640956ee35301 (diff)
downloadguix-7fb18f578aa06be524f7b06ba36aab18b1a82cb8.tar
guix-7fb18f578aa06be524f7b06ba36aab18b1a82cb8.tar.gz
gnu: Import (guix licenses) with #:prefix.
* gnu/packages/crypto.scm: Add 'license:' #:prefix for (guix licenses). Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/crypto.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index f167f3320c..041dc2015b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -29,7 +29,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages serialization)
#:use-module (gnu packages tls)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -54,7 +54,7 @@
(description
"Sodium is a new easy-to-use high-speed software library for network
communication, encryption, decryption, signatures, etc.")
- (license isc)
+ (license license:isc)
(home-page "http://libsodium.org")))
(define-public signify
@@ -91,10 +91,11 @@ OpenBSD tool of the same name.")
(home-page "https://github.com/aperezdc/signify")
;; This package includes third-party code that was originally released under
;; various non-copyleft licenses. See the source files for clarification.
- (license (list bsd-3 bsd-4 expat isc public-domain
- (non-copyleft "file://base64.c"
- "See base64.c in the distribution for
- the license from IBM.")))))
+ (license (list license:bsd-3 license:bsd-4 license:expat license:isc
+ license:public-domain (license:non-copyleft
+ "file://base64.c"
+ "See base64.c in the distribution for
+ the license from IBM.")))))
(define-public opendht
@@ -146,4 +147,4 @@ OpenBSD tool of the same name.")
(description "OpenDHT is a Distributed Hash Table (DHT) library. It may
be used to manage peer-to-peer network connections as needed for real time
communication.")
- (license gpl3)))
+ (license license:gpl3)))