aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-17 21:50:48 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-01 17:56:00 +0200
commit7b7562d930648380d03c2ffa06cbd0f145791ce9 (patch)
tree0787b6509e479bbfabb4f7982b941d1f859085c4
parentb6b09a93fd0d2177e702f43c566bb2b4c2d300c8 (diff)
downloadguix-7b7562d930648380d03c2ffa06cbd0f145791ce9.tar
guix-7b7562d930648380d03c2ffa06cbd0f145791ce9.tar.gz
gnu: Add python-readability-lxml.
* gnu/packages/python-xyz.scm (python-readability-lxml): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 34d6aa5ea0..74fa826889 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27967,6 +27967,38 @@ characteristics. These measures are basically linear regressions based on the
number of words, syllables, and sentences.")
(license license:asl2.0)))
+(define-public python-readability-lxml
+ (package
+ (name "python-readability-lxml")
+ (version "0.8.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/buriy/python-readability")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "13nfy2v0pbbf62jn9qwgi489gg97hbb22q6w3f78mnvjxd2m19rh"))
+ (snippet
+ #~(begin (delete-file "readability/compat/two.py")))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-v" "tests/")))))))
+ (propagated-inputs (list python-chardet python-cssselect python-lxml))
+ (native-inputs (list python-timeout-decorator python-pytest))
+ (home-page "http://github.com/buriy/python-readability")
+ (synopsis "HTML to text parser")
+ (description
+ "This package provides classes and function that strip gratuitous markup
+from web pages to make them easier to read.")
+ (license license:asl2.0)))
+
(define-public python-listparser
(package
(name "python-listparser")