aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-01 06:27:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-10-02 15:34:30 +0300
commit6448abe39aea8644ebd2be141ab60bcbc5de085e (patch)
tree22f6a145a63d9aa3e75d4be073f350d534a0da67
parent5bd048debf2aca40e353956c9e54d3a267ec7eb2 (diff)
downloadguix-6448abe39aea8644ebd2be141ab60bcbc5de085e.tar
guix-6448abe39aea8644ebd2be141ab60bcbc5de085e.tar.gz
gnu: python-socks: Update to 2.0.3.
* gnu/packages/python-web.scm (python-socks): Update to 2.0.3. [arguments]<#:phases>: Remove trailing #t. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94544e1e74..f1eb4fb7b5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6555,14 +6555,14 @@ your code non-blocking and speedy.")
(define-public python-socks
(package
(name "python-socks")
- (version "1.2.4")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-socks" version))
(sha256
(base32
- "1n6xb18jy41ybgkmamakg6psp3qididd45qknxiggngaiibz43kx"))))
+ "12msk06c0glljcrx1byd78xgv05lxw81vknqwhn8ccs7an7cmag3"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; tests not included
@@ -6571,8 +6571,7 @@ your code non-blocking and speedy.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "tests/" "-s"))
- #t)))))
+ (invoke "pytest" "tests/" "-s")))))))
(propagated-inputs
(list python-async-timeout python-curio python-trio))
(native-inputs