aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-30 08:28:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-30 09:00:43 +0200
commit575da30495a69e57b44d41e164dc711f26deebc6 (patch)
tree5841e2c275f0a616e77565b3f914251baf2eeb94
parenta70c67cfe75031746d1f73ba76b6d83b95ea1cf7 (diff)
downloadguix-575da30495a69e57b44d41e164dc711f26deebc6.tar
guix-575da30495a69e57b44d41e164dc711f26deebc6.tar.gz
gnu: emacs-pg: Update to 0.16.
* gnu/packages/emacs-xyz.scm (emacs-pg): Update to 0.16. [source]<origin>: Change upstream repository, the older one being unmaintained. [home-page]: Update accordingly. [description]: Expound it. [license]: Set to GPL2+.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0671eb4ac6..68e573741a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19056,24 +19056,27 @@ match and total match information in the mode-line in various search modes.")
(license license:gpl3+)))
(define-public emacs-pg
- (let ((commit "4f6516ec3946d95dcef49abb6703cc89ecb5183d"))
- (package
- (name "emacs-pg")
- (version (git-version "0.1" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference (url "https://github.com/cbbrowne/pg.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zh7v4nnpzvbi8yj1ynlqlawk5bmlxi6s80b5f2y7hkdqb5q26k0"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/cbbrowne/pg.el")
- (synopsis "Emacs Lisp interface for PostgreSQL")
- (description
- "This package provides an Emacs Lisp interface for PostgreSQL.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-pg")
+ (version "0.16")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/emarsden/pg-el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jdnslpgdm16klaga02p33g7c8bjzg164kxz3jd7gs5v9gqa6ppz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emarsden/pg-el")
+ (synopsis "Emacs Lisp interface for PostgreSQL")
+ (description
+ "This module lets you access the PostgreSQL object-relational DBMS from
+Emacs, using its socket-level frontend/backend protocol. The module is
+capable of automatic type coercions from a range of SQL types to the
+equivalent Emacs Lisp type. This is a low level API, and won't be useful to
+end users.")
+ (license license:gpl2+)))
(define-public emacs-finalize
(package