aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-21 10:54:10 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-28 23:15:29 +0200
commit48c938fbc7267cbb7f7d223cffee482b11c3b7d8 (patch)
treeb76e72693d5031d54dbd789173381cbcddd7b151
parentf63adbf6f91ca77b133212e84a6cef7ac12d9b2a (diff)
downloadguix-48c938fbc7267cbb7f7d223cffee482b11c3b7d8.tar
guix-48c938fbc7267cbb7f7d223cffee482b11c3b7d8.tar.gz
gnu: Add texlive-babel-czech.
* gnu/packages/tex.scm (texlive-babel-czech): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2dc052b1a7..e5e7921ad7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11196,6 +11196,33 @@ mechanism. Line numbering may be extended to footnote lines, using the
fnlineno package.")
(license license:lppl1.3a+)))
+(define-public texlive-babel-czech
+ (let ((template (simple-texlive-package
+ "texlive-babel-czech"
+ (list "/source/generic/babel-czech/")
+ (base32
+ "1274pzgdya7gkvxjmdm3v5rb7hc0sj6mqn9pd8y9418yx5449spg"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/babel-czech")
+ ((#:build-targets _ '())
+ ''("czech.ins")) ; TODO: use dtx and build documentation
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/generic/babel-czech")))))))
+ (home-page "https://www.ctan.org/pkg/babel-czech")
+ (synopsis "Babel support for Czech")
+ (description
+ "This package provides the language definition file for support of
+Czech in @code{babel}. Some shortcuts are defined, as well as translations to
+Czech of standard ``LaTeX names''.")
+ (license license:lppl1.3+))))
+
(define-public texlive-babel-dutch
(let ((template (simple-texlive-package
"texlive-babel-dutch"