aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-29 02:31:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-29 02:31:59 +0200
commit3ee9355e2fd2d0fcee1076ca1160ba5881b73da8 (patch)
treef8c3480d871ffc12e8b4a4a1e31231b9f3194ab8
parent812c1819a0ca740d2ab165d691806def2a2d119f (diff)
downloadguix-3ee9355e2fd2d0fcee1076ca1160ba5881b73da8.tar
guix-3ee9355e2fd2d0fcee1076ca1160ba5881b73da8.tar.gz
gnu: python-pexpect: Add verbose test output.
Fixes <https://bugs.gnu.org/26286>. * gnu/packages/python.scm (python-pexpect, python2-pexpect)[arguments]: Add "-v" to "nosetests" command.
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f989338683..4818f86d42 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4917,7 +4917,7 @@ cluster without needing to write any wrapper code yourself.")
;; Why does it not work? Delete for now.
(delete-file "tests/test_socket.py")
#t))
- (replace 'check (lambda _ (zero? (system* "nosetests")))))))
+ (replace 'check (lambda _ (zero? (system* "nosetests" "-v")))))))
(native-inputs
`(("python-nose" ,python-nose)
("python-pytest" ,python-pytest)