aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-22 19:44:08 +0000
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:21:51 +0200
commit35c92a63245ff214dbd7fe8910b6ef8a01280e18 (patch)
tree79696ef37168a7a54fda9f9f1ac2c0b708a6f81c
parent56d8907c5ffbe9422f1b159759653715ded9d45a (diff)
downloadguix-35c92a63245ff214dbd7fe8910b6ef8a01280e18.tar
guix-35c92a63245ff214dbd7fe8910b6ef8a01280e18.tar.gz
gnu: python-cfn-lint: Update to 0.65.0.
* gnu/packages/python-web.scm (python-cfn-lint): Update to 0.65.0. [arguments]<#:phases>: Add 'skip-network-test. [propagated-inputs]: Add python-importlib-resources, python-jschema-to-python, python-sarif-om. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c088f3a8dc..1f0b43d1ad 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -711,7 +711,7 @@ decode and default on encode.
(define-public python-cfn-lint
(package
(name "python-cfn-lint")
- (version "0.54.3")
+ (version "0.65.0")
(home-page "https://github.com/aws-cloudformation/cfn-lint")
(source (origin
(method git-fetch)
@@ -721,11 +721,16 @@ decode and default on encode.
(file-name (git-file-name name version))
(sha256
(base32
- "106qf19n2k6sdjkb4006aidibd24qqiw901c1613xgjpnyw4dyl6"))))
+ "1rfacp39jssrbchrzb49vwrqyzhx5v7jfcgngqnb9r7qfs4bwi3w"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-network-test
+ (lambda _
+ ;; This test requires networking.
+ (substitute* "test/unit/module/formatters/test_formatters.py"
+ (("def test_sarif_formatter") "def _test_sarif_formatter"))))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
@@ -745,11 +750,14 @@ decode and default on encode.
(list python-pydot python-mock))
(propagated-inputs
(list python-aws-sam-translator
+ python-importlib-resources
+ python-jschema-to-python
python-jsonpatch
python-jsonschema
python-junit-xml
python-networkx
python-pyyaml
+ python-sarif-om
python-six))
(synopsis "Validate CloudFormation templates")
(description