aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-28 22:03:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-28 22:10:33 +0200
commit352e02a7686c12165843a15d95d873d4bc85ffe8 (patch)
tree76a6a7b1e845627e829ac3c9ef92f8c7db616557
parent190c48c6ba0c4844185d93a20fdf33227cd29c76 (diff)
downloadguix-352e02a7686c12165843a15d95d873d4bc85ffe8.tar
guix-352e02a7686c12165843a15d95d873d4bc85ffe8.tar.gz
gnu: Add r-ggghost.
* gnu/packages/cran.scm (r-ggghost): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 003a9624d9..6a561473fc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20010,6 +20010,26 @@ inline CSS directives, and it can be rendered both with and without word
wrap.")
(license license:expat)))
+(define-public r-ggghost
+ (package
+ (name "r-ggghost")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggghost" version))
+ (sha256
+ (base32
+ "0kvsjadxxdf6yvzk4a6yqkg02q1ysslvf3m0a369bdim396z4hnv"))))
+ (properties `((upstream-name . "ggghost")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-animation r-ggplot2))
+ (home-page "https://github.com/jonocarroll/ggghost")
+ (synopsis "Capture the spirit of your ggplot2 calls")
+ (description
+ "This package lets you create a reproducible @code{ggplot2} object by
+storing the data and calls.")
+ (license license:gpl3+)))
+
(define-public r-ggtext
(package
(name "r-ggtext")