aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-18 14:09:18 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:16 +0100
commit2fd7c04984cf204dc90d5def68cad02002cd5937 (patch)
tree1744d0e6d8926113f18e0a7f976fa7d06c884fda
parent317755ff0fbd443466b162b358f650edeff10b69 (diff)
downloadguix-2fd7c04984cf204dc90d5def68cad02002cd5937.tar
guix-2fd7c04984cf204dc90d5def68cad02002cd5937.tar.gz
gnu: Add GenomicFeatures.
* gnu/packages/bioinformatics.scm (r-genomicfeatures): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c7728160e6..34a0e76f75 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3746,6 +3746,47 @@ built-in). The user may export/import tracks to/from the supported browsers,
as well as query and modify the browser state, such as the current viewport.")
(license license:artistic2.0)))
+(define-public r-genomicfeatures
+ (package
+ (name "r-genomicfeatures")
+ (version "1.22.7")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomicFeatures" version))
+ (sha256
+ (base32
+ "1jb4s49ar5j9qslpd3kfdg2wrl4q7ciysd55h9a7zvspymxcngq8"))))
+ (properties
+ `((upstream-name . "GenomicFeatures")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biomart" ,r-biomart)
+ ("r-biostrings" ,r-biostrings)
+ ("r-dbi" ,r-dbi)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (home-page "http://bioconductor.org/packages/GenomicFeatures")
+ (synopsis "Tools for working with transcript centric annotations")
+ (description
+ "This package provides a set of tools and methods for making and
+manipulating transcript centric annotations. With these tools the user can
+easily download the genomic locations of the transcripts, exons and cds of a
+given organism, from either the UCSC Genome Browser or a BioMart
+database (more sources will be supported in the future). This information is
+then stored in a local database that keeps track of the relationship between
+transcripts, exons, cds and genes. Flexible methods are provided for
+extracting the desired features in a convenient format.")
+ (license license:artistic2.0)))
+
(define-public r-qtl
(package
(name "r-qtl")