aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-04-08 00:59:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-04-18 21:36:26 +0300
commit190f460f983e5cfbfe395b04503520513390f63c (patch)
tree2daee9ec65862258d347415f13ab3811ea29481b
parent6a825d8c0d4663169e17d60a67f92ed690fd060e (diff)
downloadguix-190f460f983e5cfbfe395b04503520513390f63c.tar
guix-190f460f983e5cfbfe395b04503520513390f63c.tar.gz
gnu: Add node-semver.
* gnu/packages/node-xyz.scm (node-semver): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/node-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 44236ec469..27cd5c18b7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -244,3 +245,26 @@ protocol used in @code{node-lynx}.")
(description "This package provides the Node.js @code{util.deprecate()}
function with browser support.")
(license license:expat)))
+
+(define-public node-semver
+ (package
+ (name "node-semver")
+ (version "7.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npm/node-semver.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06biknqb05r9xsmcflm3ygh50pjvdk84x6r79w43kmck4fn3qn5p"))))
+ (build-system node-build-system)
+ (arguments
+ `(#:tests? #f)) ;; FIXME: Tests depend on node-tap
+ (home-page "https://github.com/npm/node-semver")
+ (synopsis "Parses semantic versions strings")
+ (description
+ "@code{node-semver} is a JavaScript implementation of the
+@uref{https://semver.org/, SemVer.org} specification.")
+ (license license:isc)))