aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit0d7edc4d8b3ebd5682cca2331c767b661cd9accd (patch)
treec3bf6c37cbb8951efb298111f7c2968370a1f900
parentccb119f6146d52d4236e9d86bd586c57bd98ff2e (diff)
downloadguix-0d7edc4d8b3ebd5682cca2331c767b661cd9accd.tar
guix-0d7edc4d8b3ebd5682cca2331c767b661cd9accd.tar.gz
gnu: Add trytond-account-stock-landed-cost-weight.
* gnu/packages/tryton.scm (trytond-account-stock-landed-cost-weight): New variable.
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 81c00d81e6..f08fe5fca2 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1199,6 +1199,34 @@ continental accounting model for stock valuation.")
allocate landed cost on Supplier Shipments after their reception.")
(license license:gpl3+)))
+(define-public trytond-account-stock-landed-cost-weight
+ (package
+ (name "trytond-account-stock-landed-cost-weight")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_stock_landed_cost_weight" version))
+ (sha256
+ (base32 "10i0ww3k2cgdg227lv6h8ag2j6rm07maylbh3n0grwxfy8dbq34m"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_stock_landed_cost_weight"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account-stock-landed-cost" ,trytond-account-stock-landed-cost)
+ ("trytond-product" ,trytond-product)
+ ("trytond-product-measurements" ,trytond-product-measurements)
+ ("trytond-stock-shipment-measurements"
+ ,trytond-stock-shipment-measurements)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-account-stock-landed-cost-weight")
+ (synopsis "Tryton module for landed cost per weight")
+ (description "The @emph{Account Stock Landed Cost Weight} Tryton module
+adds an allocation method based on weight of each line. The Weight is taken
+from the Product Measurements")
+ (license license:gpl3+)))
+
(define-public trytond-analytic-account
(package
(name "trytond-analytic-account")