aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-05-03 16:35:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-05-03 16:35:37 +0300
commit0c5658df966c93ec37750e8be94e89889db31979 (patch)
treebebd91b768626073920d7187878be8a365fd3ac7
parent723f0ce79745e346ac45cbbc8aed7bcbe32075c9 (diff)
downloadguix-0c5658df966c93ec37750e8be94e89889db31979.tar
guix-0c5658df966c93ec37750e8be94e89889db31979.tar.gz
gnu: Add gcc@7.
* gnu/packages/gcc.scm (gcc@7): New variable.
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b083a6d69d..39e1aee2ec 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -399,6 +399,19 @@ Go. It also includes runtime support libraries for these languages.")
"17xjz30jb65hcf714vn9gcxvrrji8j20xm7n33qg1ywhyzryfsph"))
(patches (search-patches "gcc-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
+(define-public gcc-7
+ (package
+ (inherit gcc-6)
+ (version "7.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "05xwps0ci7wgxh50askpa2r9p8518qxdgh6ad7pnyk7n6p13d0ca"))
+ (patches (search-patches "gcc-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions and the gfortran definition