aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-27 11:10:44 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-27 11:10:44 +0000
commitcf199bef76fac014fa2d6d9a2da8f087046711f9 (patch)
treeb4b0d560091161c8bb651ade331285071c580ee7
parente74e7bf75ceb1c9eaaed419e996a2774e9c818ee (diff)
downloadguix-cf199bef76fac014fa2d6d9a2da8f087046711f9.tar
guix-cf199bef76fac014fa2d6d9a2da8f087046711f9.tar.gz
rust-block-cipher-trait-0.6
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0c51df4dd1..3850217305 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2570,6 +2570,28 @@ extension of blocks.")
ciphers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-block-cipher-trait-0.6
+ (package
+ (name "rust-block-cipher-trait")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "block-cipher-trait" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x273w6fwka0i48nrv428birdrs2jz6jdnmc0dhc1rq9pm4lv4hw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-generic-array" ,rust-generic-array-0.8))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "Block cipher algorithms")
+ (description "This package provides a collection of block cipher
+algorithms. This package is deprecated. Please use block-cipher instead")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-block-cipher-trait-0.4
(package
(name "rust-block-cipher-trait")