aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-27 11:26:51 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-27 11:26:51 +0000
commitbe5ca84c2f08297ba7bd69762060b24c61be07b3 (patch)
tree72522395f39f04d246012e1653a6e7063196ca83
parent3807e6dfc7e58b8d7e052992bab497cdcf5b3a9c (diff)
downloadguix-be5ca84c2f08297ba7bd69762060b24c61be07b3.tar
guix-be5ca84c2f08297ba7bd69762060b24c61be07b3.tar.gz
gnu: Add rust-mach.
* gnu/packages/crates-io.scm (rust-mach): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5ed959bbdb..f9833d9f9c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33886,3 +33886,29 @@ formatters with per-field documentation generated for each structure.
(description
"This package provides the raw data needed to convert to and from HTML entities.")
(license license:expat)))
+
+(define-public rust-mach
+ (package
+ (name "rust-mach")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mach" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yksa8lwzqh150gr4417rls1wk20asy9vhp8kq5g9n7z58xyh8xq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core-1))))
+ (home-page "")
+ (synopsis
+ "A Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX.")
+ (description
+ "This package provides a Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX.")
+ (license "")))