aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-27 11:28:02 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-27 11:28:02 +0000
commit82969b4c113e9dacb4cb331d603f28a20255bcff (patch)
tree3177bf86e76c05fc5c47743a3b13c08aba7b0d92
parent2a93d9c26b86361ec055c9f6a129e69e59b0568f (diff)
downloadguix-82969b4c113e9dacb4cb331d603f28a20255bcff.tar
guix-82969b4c113e9dacb4cb331d603f28a20255bcff.tar.gz
gnu: Add rust-pretty-hex.
* gnu/packages/crates-io.scm (rust-pretty-hex): New variable.
-rw-r--r--gnu/packages/crates-io.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af29759da9..7b0704727d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34089,3 +34089,52 @@ division with overflow protection
division with overflow protection
")
(license license:expat)))
+
+(define-public rust-pretty-hex
+ (package
+ (name "rust-pretty-hex")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pretty-hex" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c91f9sdwmn3mz2d414dp1xk4iw0k1nsif7lyqvhklzh57arjp5w"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-heapless" ,rust-heapless-0.5))))
+ (home-page
+ "https://github.com/wolandr/pretty-hex")
+ (synopsis
+ "Pretty hex dump of bytes slice in the common style.")
+ (description
+ "Pretty hex dump of bytes slice in the common style.")
+ (license license:expat)))
+
+(define-public rust-gstreamer-rs-lgpl-docs
+ (package
+ (name "rust-gstreamer-rs-lgpl-docs")
+ (version "0.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gstreamer-rs-lgpl-docs" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06k4mr6478463q7hhsl4a252nhzf0b2qjqla3xhlh20ma0hz8912"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-rustdoc-stripper" ,rust-rustdoc-stripper-0.1))))
+ (home-page "https://gstreamer.freedesktop.org")
+ (synopsis
+ "LGPL-licensed docs for gstreamer-rs crates")
+ (description
+ "LGPL-licensed docs for gstreamer-rs crates")
+ (license license:lgpl2.0)))