aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-27 11:30:12 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-27 11:30:12 +0000
commit22397fda532b134fd1ab5609751f86d3744e2bfa (patch)
treeb11923876fda48e40b93ab27c2f92222ec2c4ea9
parentc14b818f15d2b7984754b98c3602ff3b726d494a (diff)
downloadguix-22397fda532b134fd1ab5609751f86d3744e2bfa.tar
guix-22397fda532b134fd1ab5609751f86d3744e2bfa.tar.gz
gnu: Add rust-newtype-derive.
* gnu/packages/crates-io.scm (rust-newtype-derive): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 14130f442a..d818b23c07 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34662,3 +34662,29 @@ division with overflow protection
(description
"This crate provides the `macro_attr!` macro that enables the use of custom, macro-based attributes and derivations. Supercedes the `custom_derive` crate.")
(license (list license:expat license:asl2.0))))
+
+(define-public rust-newtype-derive
+ (package
+ (name "rust-newtype-derive")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "newtype-derive" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1v3170xscs65gjx5vl1zjnqp86wngbzw3n2q74ibfnqqkx6x535c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-custom-derive" ,rust-custom-derive-0.1))
+ #:cargo-inputs
+ (("rust-rustc-version" ,rust-rustc-version-0.1))))
+ (home-page "")
+ (synopsis
+ "This crate provides macros for deriving common traits for newtype structures.")
+ (description
+ "This crate provides macros for deriving common traits for newtype structures.")
+ (license (list license:expat license:asl2.0))))